Quick Tech Tip - Rails and Amazon ECS and 'Missing' Gems

I was trying to get my rails app to properly search amazon, using the amazon-ecs library, but could never get the local server to start up. Turns out the problem was in my environment.rb file. I had entered: config.gem "amazon-ecs" The error I was getting was a big stack trace that ended with: I was approaching the point of screaming back, "I ALREADY RAN THE INSTALL YOU STUPID MACHINE!" However, it turns out you also need to specify the library too: config.gem "amazon-ecs", :lib => "amazon/ecs"

I was trying to get my rails app to properly search amazon, using the amazon-ecs library, but could never get the local server to start up. Turns out the problem was in my environment.rb file. I had entered:

config.gem “amazon-ecs”

The error I was getting was a big stack trace that ended with:

I was approaching the point of screaming back, “I ALREADY RAN THE INSTALL YOU STUPID MACHINE!” However, it turns out you also need to specify the library too:

config.gem “amazon-ecs”, :lib => “amazon/ecs”
Tags:

Copyright © 2017 - Scott Williams - Powered by Octopress